aboutsummaryrefslogtreecommitdiff
path: root/pyproject.toml
diff options
context:
space:
mode:
authorHugo Hörnquist <hugo@lysator.liu.se>2023-09-18 18:04:51 +0200
committerHugo Hörnquist <hugo@lysator.liu.se>2023-09-18 18:07:15 +0200
commit560d5191c8df27e35be57e889cccbde1a7a9635c (patch)
tree6a7bcdafd63f37097cf21372ba99d8cfe090262a /pyproject.toml
parentUpdate readme. (diff)
downloadrainbow-parenthesis-560d5191c8df27e35be57e889cccbde1a7a9635c.tar.gz
rainbow-parenthesis-560d5191c8df27e35be57e889cccbde1a7a9635c.tar.xz
Work on making program ready for packaging.v0.2
Diffstat (limited to 'pyproject.toml')
-rw-r--r--pyproject.toml23
1 files changed, 19 insertions, 4 deletions
diff --git a/pyproject.toml b/pyproject.toml
index c95cc69..6e701ae 100644
--- a/pyproject.toml
+++ b/pyproject.toml
@@ -1,6 +1,5 @@
[project]
name = "rainbow-parenthesis"
-version = "0.1"
description = "Add rainbow parenthesis to strings."
# Might work with lower, possibly test this.
requires-python = ">=3.10"
@@ -8,14 +7,16 @@ license = { file = "LICENSE" }
authors = [
{ name = "Hugo Hörnquist", email = "hugo@lysator.liu.se" },
]
+keywords = []
classifiers = [
"Programming Language :: Python :: 3",
"Development Status :: 4 - Beta",
"Environment :: Console",
-# "License :: OSI Approved :: GNU General Public License v3 or latel (GPLv3+)",
+ "License :: OSI Approved :: GNU General Public License v3 or later (GPLv3+)",
"Intended Audience :: Developers",
"Typing :: Typed",
]
+dynamic = ["version"]
[project.urls]
homepage = "https://git.hornquist.se/rainbow-parenthesis"
@@ -24,11 +25,25 @@ repository = "https://git.hornquist.se/rainbow-parenthesis"
[project.scripts]
rainbow = "rainbow_parenthesis.__main__:main"
+[project.optional-dependencies]
+doc = [
+ 'sphinx'
+]
+check = [
+ "mypy",
+ "flake8",
+]
[build-system]
-requires = ["setuptools"]
+requires = [
+ "setuptools",
+ "wheel",
+]
build-backend = "setuptools.build_meta"
# requires = ["setuptools>=40.6.0"]
[tool.setuptools]
-packages = ["rainbow_parenthesis"]
+packages = ["rainbow_parenthesis"]
+
+[tool.setuptools.dynamic]
+version = {attr = "rainbow_parenthesis.__version__"}