aboutsummaryrefslogtreecommitdiff
path: root/system/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'system/PKGBUILD')
-rw-r--r--system/PKGBUILD15
1 files changed, 11 insertions, 4 deletions
diff --git a/system/PKGBUILD b/system/PKGBUILD
index 2edfb132..4482f371 100644
--- a/system/PKGBUILD
+++ b/system/PKGBUILD
@@ -8,16 +8,23 @@ license=('AGPL')
depends=('guile>=2.2')
makedepends=('ruby-sass')
optdepends=('vdirsyncer': 'Download calendar files')
-source=("https://github.com/HugoNikanor/$pkgname/archive/v$pkgver.tar.gz")
+source=(
+ calp.service
+ config.scm
+ "https://github.com/HugoNikanor/$pkgname/archive/v$pkgver.tar.gz"
+)
build() {
make
}
-check() {
- make test
-}
+# check() {
+# make test
+# }
package() {
make DESTDIR="$pkgdir" install
+ install -m 644 -D -t $pkgdir/usr/lib/systemd/system calp.service
+ install -m 644 -D -t $pkgdir/etc/calp/config.scm config.scm
}
+