summaryrefslogtreecommitdiff
path: root/PKGBUILD
diff options
context:
space:
mode:
authorHugo Hörnquist <hugo@lysator.liu.se>2024-01-06 04:39:42 +0100
committerHugo Hörnquist <hugo@lysator.liu.se>2024-01-06 04:39:42 +0100
commitf48a77b617930f88bb0dd124881493d213b6a220 (patch)
treeebf674e05151bbb71a1bf5897b53cf6b8b4d130d /PKGBUILD
downloadlaga-signatur-f48a77b617930f88bb0dd124881493d213b6a220.tar.gz
laga-signatur-f48a77b617930f88bb0dd124881493d213b6a220.tar.xz
Initial packaging.
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD23
1 files changed, 23 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 0000000..1c1d461
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,23 @@
+# Maintainer: Hugo Hörnquist <hugo@lysator.liu.se>
+
+pkgname=laga-signatur
+pkgver=1.1
+pkgrel=1
+pkgdesc='Generate email signatures specifying which laws you follow'
+arch=(any)
+license=(LGPL)
+depends=(boost-libs libxdg-basedir)
+makedepends=(boost cmake)
+url=https://git.lysator.liu.se/hugo/${pkgname}
+source=("${url}/-/archive/v${pkgver}/${pkgname}-v${pkgver}.tar.gz")
+sha256sums=('2e7e276f9e9fe16b7625297fe095f20e212358b3cfccd9d54aecd5fe7dc8f70a')
+
+build() {
+ cmake -B build -S "$srcdir/$pkgname-v$pkgver" --install-prefix /usr
+ cmake --build build
+}
+
+package() {
+ cd build
+ make DESTDIR=$pkgdir install
+}