aboutsummaryrefslogtreecommitdiff
path: root/pyproject.toml
diff options
context:
space:
mode:
Diffstat (limited to '')
-rw-r--r--pyproject.toml34
1 files changed, 34 insertions, 0 deletions
diff --git a/pyproject.toml b/pyproject.toml
new file mode 100644
index 0000000..c95cc69
--- /dev/null
+++ b/pyproject.toml
@@ -0,0 +1,34 @@
+[project]
+name = "rainbow-parenthesis"
+version = "0.1"
+description = "Add rainbow parenthesis to strings."
+# Might work with lower, possibly test this.
+requires-python = ">=3.10"
+license = { file = "LICENSE" }
+authors = [
+ { name = "Hugo Hörnquist", email = "hugo@lysator.liu.se" },
+]
+classifiers = [
+ "Programming Language :: Python :: 3",
+ "Development Status :: 4 - Beta",
+ "Environment :: Console",
+# "License :: OSI Approved :: GNU General Public License v3 or latel (GPLv3+)",
+ "Intended Audience :: Developers",
+ "Typing :: Typed",
+]
+
+[project.urls]
+homepage = "https://git.hornquist.se/rainbow-parenthesis"
+repository = "https://git.hornquist.se/rainbow-parenthesis"
+
+[project.scripts]
+rainbow = "rainbow_parenthesis.__main__:main"
+
+
+[build-system]
+requires = ["setuptools"]
+build-backend = "setuptools.build_meta"
+# requires = ["setuptools>=40.6.0"]
+
+[tool.setuptools]
+packages = ["rainbow_parenthesis"]